Canada Kicks Ass
CKA Database Upgrade

REPLY



Canadaka @ Wed Feb 16, 2011 6:34 pm

Sorry the site was down for over an hour this afternoon. I was at the data center working on the servers.

The 2nd server which usually acts as a dedicated database server has not been in use since last August, one of the SCSI drives in it was failing. Today I replaced that drive with a new one and resetup the dedicated database server.

I also did a bunch of housekeeping updates and a full offsite backup.

But since there is a change to the location of the database along with an upgrade from MySQL 5.5 to 5.5, there might be some things broken. So if you find anything not working or errors, please let me know!

Having 2 servers working again should help to keep things speedy during peak times and heavy load.

   



Canadaka @ Wed Feb 16, 2011 6:38 pm

Also i have a bad headache from 3 hours in the data centre, the fans are SOOO loud.

   



raydan @ Wed Feb 16, 2011 7:44 pm

$1:
MySQL 5.5 to 5.5...

That's some upgrade! 8O

   



Unsound @ Wed Feb 16, 2011 7:48 pm

We appreciate the hard work.

   



Hyack @ Wed Feb 16, 2011 7:48 pm

Is it just me or has the news dropped off the Home page......

   



Canadaka @ Wed Feb 16, 2011 8:12 pm

I usually only upgrade PHP or Mysql once a year, since it almost always breaks tons of stuff. This was a good opportunity and MySQL 5.5 has some big improvements.

Improved! Up to 1500% faster performance on Windows
Improved! Up to 370% faster performance on Linux
Improved! Better scalabilty on modern, multi-core, multi-CPU hardware

I still have to run CKA on PHP 5.2 a lot of the code breaks on PHP 5.3, I'll get around to upgrading all the code sometime this year.

   



ShepherdsDog @ Wed Feb 16, 2011 8:19 pm

That's some storage space you have in your building :lol:

   



Scape @ Wed Feb 16, 2011 8:23 pm

370% on Linux? Dam.

   



herbie @ Wed Feb 16, 2011 9:25 pm

No shit about 5.3
Spent half of December fixing blah blah blah is deprecated on line such and such

   



Canadaka @ Wed Feb 16, 2011 9:40 pm

FRAAAAAAAAAK i'm still having database corrupting problems on the Database server, there must be some faulty RAM on the server. I thought it was from the harddrive, which was failing but maybe not the cause of the problem.

I will have to go back into the data centre and run a full memtest86 or something like that.

I'm going to take down the site after midnight PST to do a full database repair then see how it does tommorow. See if there is any corruption done.

   



Proculation @ Wed Feb 16, 2011 9:57 pm

BONJOUR, 0, 0); DROP DATABASE CKA;

   



Proculation @ Wed Feb 16, 2011 9:58 pm

:lol:

   



Canadaka @ Thu Feb 17, 2011 2:32 am

OK Database all repaired and running good, we'll see if any errors come up today.

   



Canadaka @ Thu Feb 17, 2011 4:06 am

Well scratch that, didn't last long until database tables were corrupting. So I had to move MySQL back onto the main server again. There is obviously some bad RAM in the other server and I will have to replace it. :(

I ordered some new memory for that server, all the local stores wanted hundreds of dollars, since its old DDR 266 ram that isn't common anymore. But I found a site online from the US where it cost $89.98

   



REPLY